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1 Introduction

Standard Telephone Features
The CounterPath X-Lite 5 for Mac softphone has all standard telephone features, including:

• Call display and Message Waiting Indicator (MWI).
• Speakerphone and Mute.
• Redial, Hold, Do Not Disturb.
• Call history – list of received, missed, and dialed calls.
• Three-party conferencing.

Enhanced Features and Functions
X-Lite for Mac also supports the following features and functions:

• Video.
• Managed contact list.
• Automatic detection and configuration of audio and video devices.
• Acoustic echo cancellation, automatic gain control, voice activity detection.
• Support for the following audio codecs:

Broadvoice-32, Broadvoice-32 FEC, DVI4, DVI4 Wideband, G.711aLaw, G.711uLaw, GSM, iLBC, L16 
PCM Wideband, Speex, Speex FEC, Speex Wideband, Speex Wideband FEC.

• Support for the following video codecs:
H.263, H.263+ 1998.

• Automatic selection of the best codec based on the other party’s capability, the available bandwidth, and 
network conditions. X-Lite switches the codec within a call in response to changing network conditions.

• Compliance to 3261 SIP standard.
• STUN and ICE NAT traversal.
• Support for DTMF (RFC 2833, inband DTMF). 

SoftPhone.com Features
If you have a SoftPhone.com account, the following features are also available:

• Presence via your SoftPhone.com account. You can see the presence of any contact who also has a 
SoftPhone.com account.

• IM via your SoftPhone.com account.  You can send IMs to any contact who has a SoftPhone.com account.

For more information on SoftPhone.com and its features, see www.softphone.com.
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2 Installation and Setup

2.1 Getting Ready
Hardware and Other System Requirements 
For information on the supported hardware and other system requirements, see https://support.counterpath.com/
default.asp?W336.

Multimedia Device Requirements
X-Lite requires both speakers and a microphone to make calls. Any of the following configurations are 
acceptable:

• External speakers and microphone
• Built-in speakers and microphone
• Dual-jack multimedia headset
• USB multimedia headset
• USB phone. 

X-Lite is optimized to work with Apple iSight camera.
3
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2.2 Installing X-Lite
Run the X-Lite installer and follow the prompts in the install wizard.

If you want to configure X-Lite immediately, then at the final step of the wizard, select Launch X-Lite. The first 
time you start X-Lite, a video about Softphone.com appears. Then the X-Lite softphone appears.

You can use X-Lite without signing up for Softphone.com, but if you do sign up for Softphone.com you will be 
able to make freee phone calls to people outside your enterprise and you will have access to IM and presence 
features. For more information, see www.softphone.com.

If X-Lite is not already running, start it as you would any other program.

You can set up X-Lite in one of these ways:

• With your PBX account (in other words, your office phone number). 
• With your PBX account and with SoftPhone.com .
• With a SoftPhone.com  account only.

This guide explains how to set up your PBX account. For information on the SoftPhone.com  account, see 
www.softphone.com.
4
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Setting up your PBX Account
To use your PBX account, you must have network access to your enterprise LAN, which means you must be 
using a computer on the LAN or using a computer that has VPN access to the LAN.

1. Obtain your PBX account credentials from your IT administrator or VoIP service provider: 

• User name and password
• Authorization Name (if applicable)
• Domain
• Firewall traversal and other network information; see “Configuring X-Lite” on page 23.

2. From the menu bar, choose X-Lite > Preferences > Accounts. The SIP Account window appears.

3. In the Account tab, complete the User Details area with your account credentials. 

4. Complete the remaining tabs as specified by your IT administrator or VoIP service provider, or to suit your 
setup. Settings that you may need to change immediately include:

• Account tab, Domain Proxy area.
• Topology tab, if your computer is on a network and/or behind a firewall.

For more information, see “Configuring X-Lite” on page 23.

Setting up for Voicemail
Your enteprise or VoIP service provider may offer voicemail. If it does, then you can set up some voicemail 
features in X-Lite. See page 25.
5
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Setting up a Contact List
Typically, you will want to create contacts in order to easily make calls. You can add addresses to the Contact 
list one by one. See page 20.

2.3 Troubleshooting
X-Lite includes tools for helping you troubleshoot problems. From the menu, choose Help > Troubleshooting.

• Devices tab: You can verify that your microphone and speakers are working and can set the volume to a 
comfortable level without having to actually place a phone call.

• Audio tab: While you are on a phone call, you can test the quality of the audio. Note that to perform a valid 
test, you should be on an established call (not a call attempt). 

• Video tab: You can verify that your camera is working.
• Diagnostics tab: If none of the other tabs help you solve your problem.

2.4 Checking for X-Lite Updates
To check for updates to X-Lite, from the menu bar, choose Help > Check for updates. The Auto Update window 
appears.

• If a new version of the software is available, you can download it from this window.
• If no newer version is available, this window informs you that your version is up to date.
6



3 Using X-Lite

3.1 The Onscreen Softphone 

Compact View

To display a compact view of the softphone, hide the dialpad and hide all the resources tabs (View > Hide).

Call entry field 
See page 9.

Resources. 
See page 19

Close window

Show/hide dial pad

Minimize to dock

Resize softphone

The dashboard

The Call button

These buttons are activated if you have a
SoftPhone.com  account.  See 
www.softphone.com.
7



CounterPath Corporation
The X-Lite Menu

The menu contains the following items that are specific to X-Lite:

X-Lite
• X-Lite > Sign in to SoftPhone.com . For information on this menu, see www.softphone.com.
• X-Lite > Share with Contacts. For information on this menu, see www.softphone.com.
• X-Lite > Preferences. See page 23. 

View

Changes how X-Lite looks. Also lets you view the message archive.

Contacts

Lets you work with contacts. For information on the Find contacts menu item, see www.softphone.com.

Actions
• Lists the actions that you can perform, depending on the current “state” of X-Lite. For example, if a contact 

is selected, it lists all the actions that can be performed on that contact. 
• For information on the Invite to SoftPhone.com  menu item, see www.softphone.com.

Help

Provides access to various features. 

The X-Lite Toolbar
The toolbar has various buttons, including the message waiting indicator (MWI) and missed calls indicator. 
Hover over each button for a description.
8
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3.2 Placing a Call
You can place one more call when another call is already in progress.

You can specify the number to call in any of these ways:

• Type the number on the dialpad or computer keyboard, then click Call or Enter.
• Control-click an entry in the Contacts or History tab and choose Call or Video Call.
• Drag-and-drop an entry in the Contacts or History tab. 
• Hover over the right side of a contact to reveal the click-to-call button. Click to place a call using the 

primary phone number for this contact.
• Redial: click Call or click the down arrow and select a recent call and click Call.

The number can be in several formats:

• An extension such as 390 or 1300. X-Lite will place the call without going through your PBX.
• A phone number outside your PBX. See page 42 to set up correctly to place these calls.
• A phone number and extension with a separator in between. For example, 6045551222x1300. X-Lite will 

dial the phone number, wait for the call to get established, then dial the extension.

Call entry field

Click to place the call

Auto-complete suggestions

The first time you make a call, select Softphone > Preferences > Dialing 
Preferences and set your dialing preferences. See page 42.

Place the call. See below 
for different ways to specify 
the number.

The outgoing call opens in its own call panel, below any other 
existing call panels. You will hear a ringing tone while X-Lite 
attempts to make a connection.
9
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Valid separators are: x   extension   ext   ; (semi-colon) , (comma)

If X-Lite sees that the phone number is actually your own PBX, it drops the phone number and dials the 
extension directly.

• A SIP  address at a different domain, for example, ewilding@domainA.com. Speak to your VoIP service 
provider or IT administrator about whether you can phone someone with a different domain from your own. 

Dealing with an Auto Attendant

If you know that your call will be answered by an auto attendant and you know what menu items you will 
choose, you can include those menu items (DTMF) in the phone number when you dial it:

• Before the first DTMF number, include at least one capital P.
• You can include other Ps. Each P causes X-Lite to wait one second before sending the next character. 
• At the end of the input, you must include a ; character.

Example: To dial a number, add a 3-second delay and then press 44, enter this in the call entry field:

604551212PPP44;

Example: To dial a number, add a 6-second delay, then press 1 then 3 then 2, each with a two second delay:

604551212PPPPPP1PP3PP2;

Placing another Call
To place a new call (without hanging up on the current call), simply place the call in the normal way. A second 
call panel opens below the current call. The first call is automatically put on hold.

Existing call is automatically 
put on hold

New outgoing call

Switch between the different 
calls by clicking Resume on the 
desired call panel. That call 
becomes the active call and all 
other calls are on hold.
10
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3.3 Handling Incoming Calls
X-Lite must be running to answer incoming calls. (If X-Lite is not running, incoming calls may be directed to 
voicemail; check with your IT administrator or VoIP service provider.)

The new call appears in its own call panel. 

Action Description

Answer or Audio Click Answer or Audio
If you are on another call, that first call is automatically put on hold. You are 
now talking to the new caller.
Or press Enter (on the keyboard), if X-Lite is the active application.

Video The caller wants to include video.
Click to answer a video call and start sending your video immediately

Decline Click Decline. There will be a busy signal. The call may be directed to 
voicemail (if you have this service).
11
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3.4 Handling an Established Call

Volume control and

Speakerphone (this button is 
enabled if your computer has a 
speakerphone)

Mute

Place another call (current call is 
automatically put on hold). See page 10

Open or close the video window. If 
you close it, X-Lite stops sending 
your video to the other party.

Start your video. Even if you 
did not originally place a 
video call, you can add video 
at any time (if you have a 
camera).

Hold or resume the call

If a plus symbol appears here, 
you can add the current caller 
as a contact. 

Show/hide dialpad
12
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3.5  Handling Video Calls
Placing a Video Call

Specify the number in one of these ways:

• Type the number on the dialpad or computer keyboard, then click the arrow beside the Call button and 
choose Video call. 

• Control-click an entry in the Contacts or History tab and choose Video Call.
• Redial: click Call or click the down arrow and select a recent call and click Call.

Adding Video to an Existing Call
If you have a camera, you can click Start Video to add video to an established call. When you add video, the 
other party may (or may not) start sending their video to you.

Click the down arrow and choose Video call

Show/hide video window

Start or stop video
13
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Other Party Adds Video
If the other party starts their video, your video panel automatically opens and the video is played. You can start 
sending your own video, if desired (and assuming you have a camera) by clicking Start Video on the call panel.

Pausing and Resuming Video
Click Stop Video on the call panel or close the video window to pause sending your video.

Click Start Video to resume sending your video; the video window will open. 
14
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3.6 Three-way Calls (Conference Calls)

Starting a Conference Call

From the Dashboard

From an Existing Call 

• Enter the number or address 
by typing

• Or select from the redial list

Then choose Start conference call

• Or drag a contact or history 
item

From One Established Call

From Two Established Call
15
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Managing the Conference

Removing a Participant
To remove one call from the conference, click the down arrow beside a participant name and choose Separate. 
The call becomes a separate call.

Ending the Conference
To hang up on everyone, click the End button.

Suspending the Conference
To suspend the conference, click the Hold button. All participants are put on hold. 

Participant menu

Mute. When you mute during a video call, 
you may also want to click Stop Video to 
stop the video feed.
16
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Video Conference Calls 

Starting a Conference with Video
When you start a conference from established calls, video is included if at least one of the calls already includes 
video. Video is sent to all the participants.

When you start a conference from scratch, video is not included. You can open your video window and choose 
to add video at any time. Video is sent to all the participants.

How Video Is Shared
The conference host (the person who starts the conference) serves as the host for other video. Whatever the 
conference host is receiving will automatically be sent to the other parties. 

If the conference host pauses or stops video, other participants will no longer receive video.

“Video” appears beside each person you are 
currently sending video to

To start or stop video for one person, use the 
participant menu

Closing the video window stops 
sending video.
17
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3.7 Voicemail
If your service includes voicemail and you have set up voicemail options (page 25), then when you have 
voicemail messages, the voicemail icon appears at the top of the phone (the icon may include a number). You 
can click the icon to automatically connect to voicemail and listen to your messages.

Voicemail icon
18



4 Using Resources

4.1 Contacts Tab
If the Contacts tab is not showing, go to the menu bar and choose View > Show Contacts.

You can change the detail and layout of the contact list: from the menu bar choose Contacts and set the desired 
options.

Add a Contact

Search field
19
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Managing Contacts and Groups

Adding a Contact

Click , or control-click a group and choose Add Contact to Group. The Contact dialog appears.

Adding a Contact using an Existing Address
You can add a contact by capturing existing information: 

• If you are on a phone call with a person who is not a contact, click the Add to Contacts icon in the call 
panel.

• On the History tab, select an entry that is not a contact. Control-click and choose Add Contact.

The Contact Profile dialog appears. Complete the dialog as desired and press OK.

Changing Contact Information
To change the information for a contact, control-click the contact and choose Edit Profile. The Contact dialog 
appears (see page 20). 

Deleting a Contact
To delete one or more contacts, select them, control-click, and choose Delete or Delete Selected Items. 

Adding, Deleting or Renaming Groups
Select any group, control-click, and choose the appropriate menu item.

Contacts that have no group appear under “Ungrouped Contacts.” You can delete, but not rename, this group.

Exporting Contacts
You can export a contact list to a comma-separated file. This feature is useful, for example, if you later upgrade 
to Bria 3 and want to move over your contacts.

1. From the menu bar, choose Contacts > Export Contacts. The Export Contacts wizard starts. 

2. Select the file type and file location for the created file. 

A file of the specified type is created.

The new number appears 
in the list

To enter a phone number, select 
the type, enter the number, and 
click +
20
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4.2 The History Tab

From the menu bar, choose View > Show History.

Managing the List of Calls
You can control-click on an entry in a list to:

• Delete the call.
• Delete all entries in this list.
• Edit the profile if the entry is a contact.
• Add as contact. The Contact dialog appears. 

Phoning from History
You can control-click on an entry to place a call to this person, using the contact method that was used for this 
call. You can:

• Control-click on an entry and select Call or Video Call to place a call to this person, using the contact 
method that was used for this call. 

Outgoing call, either 
attempted or established

Incoming missed call

Incoming call that was 
answered
21
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5 Configuring X-Lite

From the menu bar, choose Bria > Preferences. The Preferences window appears.

• When configuring X-Lite the first time, click the Accounts tab and set up the account. Then complete other 
tabs as desired.

• After the initial setup, display whichever tab you want. 

5.1 Configuring Accounts: the Accounts Tab
Choose X-Lite > Preferences from the menu bar. Click the Accounts tab. The Account Settings window 
appears. 

You cannot add more than 
one account

Make sure the account is enabled Double-click the account to edit
23
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Account – General

Field Description
Account name Always MyPBX.com
Protocol Read-only. Always specifies SIP.

User Details
User ID Typically the account number for the account. For example, kperera. Provided by your IT 

administrator or VoIP service provider.
Domain For example, domainA.com. Provided by your IT administrator or VoIP service provider.
Password Provided by your IT administrator or VoIP service provider.
Display name This name is displayed in the X-Lite title bar.

Other people will see you as this name.
Authorization name May not be required. If it is required, it will be provided by your VoIP service provider.

Domain Proxy
Register with domain and receive 
calls

Check this box if you want to receive incoming calls.
Typically, this field is checked. 

Send outbound via Choose the setting specified by your IT administrator or VoIP service provider: 
• Domain: If your service requires that traffic be directed to proxies that are discovered via 

the domain.
• Proxy Address: If your enterprise or VoIP service provider has an outbound proxy address 

and requires that you provide the address to X-Lite. For the address enter a domain name 
(for example, domain.com) or an IP address (for example, 123.456.789.012). 

Fields with an asterisk are 
required
24
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Account – Voicemail

These settings let you set up to interact with your VoIP service provider’s or enterprise’s voicemail service. .
Your service provider may provide the ability to set up for voicemail outside of X-Lite, for example, by 
phoning a number and following the voice prompts, or by accessing a website. 
Check with your service provider or IT administrator to determine if another setup mechanism is available. If 
so, check what the settings are in that setup, and make sure you enter compatible information in X-Lite. 
 

Field Description
Check for voicemail Set the checkbox in one of these ways:

• Check the box if X-Lite must subscribe to be notified when there is a voicemail for 
you. In other words, to configure for “subcribe for message waiting”.

• Clear the checkbox if the service provider’s voicemail server sends notifications 
without X-Lite subscribing. In other words, to configure for “implicit subscription”.

• Clear the checkbox if the service provider does not support voicemail. 

Check with your IT administrator or VoIP service provider for the correct 
configuration.

Voicemail is offered by your enterprise or VoIP service provider; it is not part of X-
Lite. Contact your service provider for information on using voicemail.

Number to dial for checking voicemail Optional, but complete this field only if your VoIP service includes voicemail. 

• Completing this field activates the  icon on the softphone. When you click the 
icon,  X-Lite will dial this number. You will be connected to your service provider’s 
voicemail and can listen to your messages. 

• If you leave this field empty, then this icon will not work; you will have to manually 
dial this number in order to connect to voicemail.

Enter the number or SIP address provided by your IT administrator or VoIP service 
provider.
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Number for sending calls to voicemail Complete only if your VoIP service includes voicemail. Optional, but you must 
complete it if you check “Send calls to voicemail if unanswered”.
This is the number that incoming calls will be forwarded to if they are unanswered after 
the specified interval (below).
If you leave this field empty, then X-Lite will never forward calls to your service 
providers’ voicemail. However, most enterprises or VoIP service providers have their 
own mechanism for sending unanswered phone calls to voicemail. So leaving this field 
blank does not mean that forward-to-voicemail does not work. 
Enter the number provided by your IT administrator or VoIP service provider.

Send calls to voicemail if unanswered Complete only if your VoIP service includes voicemail.
To send to voicemail after the specified number of seconds. 
Your service provider may also provide a similar feature that is set up outside of X-Lite. 
If so, make sure you do not enter competing information in X-Lite and in the service 
provider’s user interface. For example, if you turn off this field, make sure the same 
feature at your service provider is also turned off. Otherwise, all your calls will continue 
to be forwarded.

Field Description
26
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Account – Topology

Field Description
Firewall traversal 
method

Choose the setting recommended by your IT administrator or VoIP service provider:
• Auto detect using ICE: Automatically determine the contact address for signaling traffic.

Advertise the local IP, public IP (discovered via STUN, if available) and media relay IP and use these to 
automatically determine the best route for media traffic during calls.

• Discover public IP address: Advertise the public IP address (discovered via STUN) for the contact 
address for signaling traffic, and for the connection address for media traffic.

• Use media relay (TURN): Advertise the public IP address (discovered via STUN) for the contact address 
for signaling traffic.

Advertise the address of a media relay server (discovered via TURN) for the connection address for 
media traffic.

• None: Advertise the local IP address only for both signaling and media traffic.
Server address • Empty: Discover the address of the firewall traversal server (the STUN or TURN server), if available, 

using DNS SRV. 
• Specified: Use the firewall traversal server specified as either an IP address or a fully qualified hostname.

If you use the “Auto detect using ICE” option, then you can only enter a STUN server here. Don’t enter 
a TURN server because when ICE is used, TURN is not supported.

Range of ports The appropriate setting depends on your computer setup:
• Checked: If your computer is behind a restrictive firewall that only allows specific port ranges to be 

used. Enter the range of ports to use for your SIP account. (You must also open those ports on your 
firewall; refer to applicable firewall documentation for information.)

• Unchecked: If your computer is not behind a restrictive firewall.   
27
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Account – Transport

Field Description
Signaling Transport Contact your IT administrator or VoIP service provider to identify the types of transport that 

are supported. Then choose a supported transport:
• Automatic: X-Lite sets up the transport based on the capabilities of the network and the 

X-Lite computer. Choose this option if you do not care which transport is used.
• TCP: This transport provides no signaling security. 
• UDP: This transport provides no signaling security. 
• TLS: Choose this option to request signaling encryption or both signaling and media 

encryption.
Encryption See the description below for more information.
28
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Account – Advanced

Field Description

Register Settings
Reregister every The time interval between X-Lite’s attempts to reregister in order to refresh the account 

registration for this account. A value of zero means not to reregister after the initial registration.
This value is placed in the “Expires” header field of the REGISTER message.

Minimum time If the reregistration fails, X-Lite will wait this amount of time, then attempt to reregister. If the 
second attempt fails, X-Lite will wait twice this time and try again, then four times this time, and 
so on, until reregistration succeeds.

Maximum time This is the maximum wait time between attempts to reregister. Once this maximum is reached, X-
Lite will wait this time for all subsequent attempts.
For example, the min. time is 20 secs, the maximum time is 120 secs. X-Lite will attempt to 
reregister as follows:Wait 20 secs; Attempt to connect; If fail, wait 40 secs; Attempt to connect; If 
fail, wait 80 secs; Attempt to connect; If fail, wait 120 secs (the maximum); Attempt to connect:If 
fail, wait 120 secs, and so on.

Timers
Enable session timers
Default session time

A session timer is a mechanism to detect whether a call session is still active from the signaling 
point of view. When the timer expires, a refresh is sent from one party to the other. The timer is 
then reset.
• Turn on to enable session timer. Enter a value in Default session time. 
• Turn off to disable session timer; refreshes will never be sent.
29
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Session timer preference This field specifies your preference for which party should send the refresh. The preference is not 
a guarantee that the refresh will be performed by the specified party. The choices are:
• None: No preference.
• Local refreshes: Your computer sends.
• Remote refreshes: The other party sends.
• UAC refreshes: The user agent client (the party that initiated establishment of the 

communications) sends.
• UAS refreshes: The user agent server (the other party) sends.

Hold Method Change this setting only if your IT administrator or VoIP service provider advises you to do so.
Send SIP keep-alives Typically on, to instruct X-Lite to send SIP keep-alive messages in order to maintain a “pinhole” 

through your firewall for SIP messaging.
Use rport Typically on.

Field Description
30
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5.2 General Preferences
From the menu bar, choose X-Lite > Preferences. The Preferences window appears. All the tabs on this window 
except for “Accounts” are preferences tabs. These tabs let you control the way that you work with X-Lite. 

The icons (other than Accounts) let you set up general features of X-Lite.

Preferences – Application

This panel lets you set your preferences for general GUI behavior.
31
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Preferences – Sounds

You can assign specific sounds to a variety of actions or “events”.

1. Select the Enable sounds check box and select the check boxes for each desired event, or clear the Enable 
sounds check box to disable all sounds.

2. If enabling sounds, you can change the sound for each event: select the individual event. The value in 
Sound preference will change. Select the desired sound.
32
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Preferences – Devices

X-Lite automatically detects devices at each startup, and selects the most appropriate device for each purpose. If 
you do not like this selection, you can override it on this panel.

If you override a selection, it will apply the next time you start X-Lite, unless the device is no longer available, 
in which case X-Lite will again select the device to use.
33
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Field Description

Headset Mode

Microphone,
Speaker 

Change these fields only if you want to override the devices that X-Lite automatically selected.
In both these fields, select the headset you are using.
The headset is the device that is usually used for the speaker (the sound you hear) and microphone 
(recording your voice). The only situation in which the headset is not used is when the Speaker 
Phone button on the dialpad is pressed. 
Therefore, unless you will always be using X-Lite in speakerphone mode, you must make a 
selection here.
Select the headset in both the Speaker device field and Microphone device field.

Zero touch device 
configuration

Typically, leave on. When device configuration is on, if you change your audio or video device, X-
Lite will automatically detect the new device and start using it.

Test Devices For information on the Test Devices button, see “Testing Audio and Video Devices” on page 47.

Speakerphone Mode

Microphone 
Speaker

Same as headset mode, but for the device to use when speakerphone is one (on the toolbar). 
Select None if you do not have a speaker phone. The Speaker Phone button on the dialpad will be 
disabled.
You can set different devices for the speaker and microphone: for example, you can set the speaker 
to the speakerphone and set the microphone to your headset.

Other Devices

Ring on The device where you want to hear the phone ringing.
Change this field only if you want to override the devices that X-Lite automatically selected.

Volume The volume of the ringer.

Camera This field appears only on versions of X-Lite that include video functionality.
Change this field only if you want to override the devices that X-Lite automatically selected.
Select the camera model.

Resolution Leave at standard, or change the size as follows:
• Set it to high if you have a good camera and a computer with a fast CPU. You will know that you 

have set the size too large if:

Your computer slows down (the video is using too much CPU)
The video shows black areas or is slow or jerky.

• Typically set it to low only in special situations, for example, when using wi-fi in a hotel. You 
will know that you have set the size too small if the video is fuzzy.

This field is identical to the Resolution field in Media Quality > Video Quality.
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Preferences – Network

Select the type of network connection for your computer.

The sliders move to show the bitrate that will be used for sending and receiving. These rates are typical rates for 
the selected configuration.

If you know that your computer and network can handle a faster sending speed, click Custom and move the 
slider. It is recommended that you not change the receiving speed.

• You will know that you have set the sending speed too high if the remote audio is garbled.
• You will know that you have set the sending speed too high if:

• The remote video shows black areas or is slow or jerky.
• The remote audio is garbled.

• You will know that you have set the sending speed too low if the audio is good but the video is of poor 
quality (grainy).
35



CounterPath Corporation
Preferences – Codecs

Audio Codecs

This panel shows all the codecs that are included in the retail version of X-Lite. You can enable or disable 
codecs as desired. 

With only one codec enabled, all calls made will use that codec. With more than one codec enabled, X-Lite 
automatically chooses the best codec based on the other party’s capability, the available bandwidth, and 
network conditions.

You cannot change the properties of any codecs.

About Codecs

Audio codecs describe the format by which audio streams are compressed for transmission over networks. 
Codecs can be categorized as either narrowband or wideband:

• Narrowband codecs work with low bandwidth such as a dialup internet connection. These codecs have a 
sampling rate of 8 kHz.

• Wideband codecs work with high bandwidths and result in better audio quality. However, they do not work 
with PSTN. These codecs have a sampling rate of 16 kHz.
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Supported Codecs

Codec Narrowband Wideband

DVI4

DVI4 Wideband

G.711aLaw *

G.711uLaw *

GSM

iLBC

L16 PCM Wideband

Speex

Speex FEC

Speex Wideband

Speex Wideband FEC

* Generally, at least one of these codecs must be enabled in order to 
place a PSTN (land line) call. 
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Video Codecs

Video codecs describe the format by which video streams are compressed for transmission over networks. 
Some codecs require less bandwidth than others, but may result in lower video quality.

You can enable or disable codecs as desired. You may decide to disable a codec even though your enterprise or 
VoIP service provider supports it.

With only one codec enabled, all calls made will use that particular compression format. With more than one 
codec enabled, X-Lite automatically chooses the best codec based on the other party’s capability, the available 
bandwidth, and network conditions. 

You cannot change the properties of any codecs.
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Preferences – Media Quality

Field Description

Audio Quality

Reduce echo Turning this feature on improves sound quality. This feature is typically on.

Reduce background noise Automatically attempts to remove background noise.
Typically on for the speakerphone.

Automatic gain control This feature is typically on.

Preserve bandwidth When this feature is on, X-Lite stops sending audio when you are not talking.
When this feature is off, X-Lite always sends audio, which uses more bandwidth but may result in 
better call quality.
Typically off. However, if you are using a slow (dial-up or ISDN) connection, you may want to turn 
it on. 

Video Quality
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Resolution Leave at standard, or change the size as follows:
• Set it to high if you have a good camera and a computer with a fast CPU. You will know that you 

have set the size too large if:

Your computer slows down (the video is using too much CPU)
The video shows black areas or is slow or jerky.

• Typically set it to low only in special situations, for example, when using wi-fi in a hotel. You 
will know that you have set the size too small if the video is fuzzy.

This field is identical to the Resolution field in Devices > Other Devices.

Field Description
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Preferences – Advanced

Field Description

Audio

DTMF You may need to change the DTMF configuration if you cannot interact with interactive voice 
response systems (auto attendants, voice-activated menus, and so on).

RTP This timer controls how calls are disconnected when X-Lite determines that there is a problem 
with the call and the other party has probably disappeared (assuming that you have not yourself 
detected the problem and hung up manually).
Typically, the timer is enabled. It is recommended that you not disable it.
You can change the length of the timer, but do not set it to less than 30 seconds.
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Preferences – Dialing Preferences

Field Description

Dial out prefix The number to dial out of your enterprise. For example, 9.

International prefix The prefix required on a phone number in order to handle this number as an international 
phone call. For example, +43. X-Lite handles international calling as follows:
• It looks at the phone number for this international prefix. 
• If it finds this prefix, the phone number is transformed so that the number can be 

successfully placed according to the phone rules for the country specified in the 
country code.

For example, if the phone number is +438901234 (meaning the number is a Swiss phone 
number) and the country code is Canada, then X-Lite replaces the + with 011 (the 
international dialing code for Canada), adds the dial out prefix (9) and places the call.

Default extension length The maximum length of extensions in your enterprise. This information must be correct 
to ensure that X-Lite can distinguish between a phone number that can be made without 
leaving your PBX and one that requires going through the PBX. 

Country code The country your phone system works in. Change this code if you go to another country, 
but only if your entrprise has an office in that country that has its own PBX. 
For example, if you go to your Geneva office and that office has its own PBX, change the 
country code to Switzerland. In this way, phone calls made to a Swiss phone number will 
be correctly placed (that is, as being placed from within Switzerland).
Do not change your country code if you go to another country but you are still connecting 
to the PBX in your home country. Speak to your IT administrator.
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Preferences – Privacy Options

This panel applies only if you have a SoftPhone.com    account. See www.softphone.com.
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A Troubleshooting
From the menu bar, choose Help > Troubleshooting. The Troubleshooting window appears.

Testing Audio Quality
While you are on a phone call, you can test the quality of the audio. Note that to perform a valid test, you should 
be on an established call (not a call attempt). 
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Testing Video Quality
While you are on a phone call, you can test the quality of the video. Note that to perform a valid test, you should 
be on an established call (not a call attempt).
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Testing Audio and Video Devices
You can verify that your microphone and speakers are working and can set the volume to a comfortable level 
without having to actually place a phone call. 
F
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Diagnostics

To start logging X-Lite activity and send a logging report to CounterPath customer support:

1. Click Start Logging. The first Diagnostics Logging window appears.

2. Select the problem you are experiencing and click Start Logging. 

3. On the second Diagnostics Logging screen, click Finish. Logging will start.

4. Perform the actions you want to capture; for example, attempt to make a phone call.

5. When done, display the first Diagnostics Logging window again and click Send Report. A window opens; 
select the report and click Open. When the report is successfully sent, a confirmation message appears on 
the first Diagnostics window.

6. Click Stop Logging. Close the Troubleshooting window.
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Broadband Broad or wide bandwidth. In data transmission, the wider the band, the more data it is 

possible to transmit in a given time span. A cable, DSL and ADSL connection to the 
network provide broadband for data transmission. A dialup or ISDN connection 
typically provide a narrow bandwidth for data transmission.

Codec The format by which audio or video streams are compressed for transmission over 
networks.

Dial plan The rules that X-Lite follows in order to interpret the phone number that the user has 
entered and to modify the number or address, as required, to ensure that the call will 
be placed successfully. 

DTMF Dual-tone multi frequency. DTMF is the system that is used in interactive voice-
response menu systems such as the menu system for accessing voicemail messages. 
The DTMF system allows the user to interact with the menu by pressing keys on a 
dialpad or keyboard.

Firewall A technology that prevents unauthorized people connecting to your computer and to 
the applications running on the computer.

IP Internet Protocol. A data-oriented protocol used for communicating data across a 
network. IP is the most common protocol used on the internet.

IP address A unique number that devices use in order to identify and communicate with each 
other on a computer network using the IP standard. 

Media In a VoIP phone call, the audio and video portion of the information in a call. 
Compare to “Signaling”.

MWI Message Waiting Indicator. An indicator that there is a voicemail message for the 
owner of an account.

Narrowband In data transmission, the wider the band, the more data it is possible to transmit in a 
given time span. A cable, DSL and ADSL connection to the network provide 
broadband for data transmission. A dialup or ISDN connection typically provide a 
narrow bandwidth for data transmission.

Proxy See SIP account.
PSTN Public Switch Telephone Network. The traditional land-line phone network.
RTP Real-time Transport Protocol. A protocol for delivering the media portion of a data 

transmission over an IP network. SRTP is another media protocol.
Signaling In a VoIP phone call, the information in a call that deals with establishing and 

controlling the connection, and managing the network. The non-signaling portion of 
the call is the Media.

SIP account An account that provides the user the ability to make VoIP phone calls. The account 
encapsulates the rules and functions the user can access.

SRTP Secure Real-time Transport Protocol. A protocol for delivering the media portion of a 
data transmission over an IP network. SRTP is a secure protocol, which means that 
the media is encrypted. RTP is another media protocol.

TCP Transmission Control Protocol. A transport protocol for delivering data over an IP 
network. Other transport protocols are TLS and UDP.

UDP User Datagram Protocol. A transport protocol for delivering data over an IP network. 
Another transport protocol is TCP. 

VoIP service provider A business that provides a VoIP service, allowing a user to connect to the internet in 
order to make VoIP phone calls using X-Lite. The VoIP service provider sets up a SIP 
account for the user. 
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