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1 Introduction

Standard Telephone Features
The CounterPath X-Lite for Windows softphone has all standard telephone features, including:

• Call display and Message Waiting Indicator (MWI).
• Speakerphone and Mute.
• Redial, Hold.
• Call history – list of received, missed, and dialed calls.
• Three-party conferencing.

Enhanced Features and Functions
X-Lite for Windows also supports the following features and functions:

• Video.
• Managed contact list.
• Automatic detection and configuration of audio and video devices.
• Acoustic echo cancellation, automatic gain control, voice activity detection.
• Support for the following audio codecs:

Broadvoice-32, Broadvoice-32 FEC, DVI4, DVI4 Wideband, G.711aLaw, G.711uLaw, GSM, iLBC, L16 
PCM Wideband, Speex, Speex FEC, Speex Wideband, Speex Wideband FEC.

• Support for the following video codecs:
H.263, H.263+ 1998.

• Automatic selection of the best codec based on the other party’s capability, the available bandwidth, and 
network conditions. X-Lite switches the codec within a call in response to changing network conditions.

• Compliance to 3261 SIP standard.
• STUN and ICE NAT traversal.
• Support for DTMF (RFC 2833, inband DTMF). 

SoftPhone.com Features
If you have a SoftPhone.com account, the following features are also available:

• Presence via your Softphone account. You can see the presence of any contact who also has a 
SoftPhone.com account.

• IM via your Softphone account.  You can send IMs to any contact who has a SoftPhone.com account.

For more information on SoftPhone.com and its features, see www,softphone.com.
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2 Installation and Setup

2.1 Getting Ready
Hardware and Other System Requirements 
For information on the supported hardware and other system requirements, see https://support.counterpath.com/
default.asp?W336.

Multimedia Device Requirements
X-Lite requires both speakers and a microphone to make calls. Any of the following configurations are 
acceptable:

• External speakers and microphone
• Built-in speakers and microphone
• Dual-jack multimedia headset
• USB multimedia headset
• USB phone. 

Video Cameras
Calls made with X-Lite will work without a video camera, but a video camera is necessary to allow other parties 
to see your image. X-Lite will work with most USB video cameras.

2.2 Installing X-Lite
Run the X-Lite installer and follow the prompts in the install wizard.

If you want to configure X-Lite immediately, then at the final step of the wizard, select Launch X-Lite. The first 
time you start X-Lite, a video about SoftPhone.com  appears. Then the X-Lite softphone appears.
3
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You can use X-Lite without signing up for SoftPhone.com , but if you do sign up for SoftPhone.com  you will 
be able to make freee phone calls to people outside your enterprise and you will have access to IM and presence 
features. For more information, see www,softphone.com.
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2.3 Configuring X-Lite
If X-Lite is not already running, start it as you would any other program: Use the Windows Start menu or 
double-click the desktop icon. X-Lite appears. 

You can set up X-Lite in one of these ways:

• With your PBX account (in other words, your office phone number). 
• With your PBX account and with SoftPhone.com .
• With a SoftPhone.com  account only.

This guide explains how to set up your PBX account. For information on the SoftPhone.com  account, see 
www.softphone.com.

Setting up your PBX Account
To use your PBX account, you must have network access to your enterprise LAN, which means you must be 
using a computer on the LAN or using a computer that has VPN access to the LAN.

1. Obtain your PBX account credentials from your IT administrator or VoIP service provider: 

• User name and password
• Authorization Name (if applicable)
• Domain
• Firewall traversal and other network information; see “Configuring X-Lite” on page 25.

2. From the X-Lite menu, choose Softphone > Account Settings. The SIP Account window appears.

3. In the Account tab, complete the User Details area with your account credentials. 
5
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4. Complete the remaining tabs as specified by your IT administrator or VoIP service provider, or to suit your 
setup. Settings that you may need to change immediately include:

• Account tab, Domain Proxy area.
• Topology tab, if your computer is on a network and/or behind a firewall.
For more information, see “Configuring X-Lite” on page 25.

Setting up for Voicemail
Your enteprise or VoIP service provider may offer voicemail. If it does, then you can set up some voicemail 
features in X-Lite. See page 27.

Setting up a Contact List
Typically, you will want to create contacts in order to easily make calls. See page 22.

2.4 Troubleshooting
X-Lite includes three tools for helping you troubleshoot problems. Choose Help > Troubleshooting and display 
the appropriate tab:

• Devices  tab: You can verify that your microphone, speakers and camera are working and can set the 
volume to a comfortable level without having to actually place a phone call.

• Audio tab: While you are on a phone call, you can test the quality of the audio. Note that to perform a valid 
test, you should be on an established call (not a call attempt).

• Diagnostics tab: You can troubleshoot other problems using diagnostics logging.  

See page 47.

2.5 Checking for X-Lite Updates
To check for updates to X-Lite, choose Help > Check for Updates. The Auto Update window appears.

• If a new version of the software is available, you can download it from this window.
• If no newer version is available, this window informs you that your version is up to date.
6



3 Using X-Lite

3.1 Starting X-Lite
If X-Lite is not already running, start it as you would any other program: Use the Windows Start menu 
or double-click the desktop icon. X-Lite appears. 

USB Device Alert
If your headset is a “HID-compliant device”, the USB Device alert may appear the first time you start X-Lite. 
You can assign functions to the headset. For example, you can set the green button so that it answers an 
incoming call.

If you click Yes, the USB Device Button Setup window appears; see page 37.

If you click No, you can still access this window from the Preferences > Devices panel (page 35). 

3.2 The Onscreen Softphone 

X-Lite menu. See below.

Resources. See page 21

Call entry field See page 10.

Dialpad

These buttons are activated if you
have a SoftPhone.com  account.  
See www,softphone.com.
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Compact View

To display a compact view of the softphone, hide the dialpad and hide all the resources tabs (View > Hide).

The X-Lite Menu

Softphone
• Sign in to SoftPhone.com . For information on this menu, see www,softphone.com.
• Share with Contacts. For information on this menu, see www,softphone.com.
• Account Settings. These settings control how X-Lite interacts with your PBX and network. See 

“Configuring your Account” on page 25.
• Preferences. These settings control the way that you work with X-Lite. See “Configuring Preferences” on 

page 33.
• Exit. To shut down X-Lite. You can also exit by pressing Ctrl+Q.

View
• Change how X-Lite looks. 

Contacts

Lets you work with contacts. Everything in this menu can also be performed directly in the contact list. 

For information on the Find contacts menu item, see www,softphone.com.

Actions

Lists the actions that you can perform, depending on the current “state” of X-Lite. For example, if a contact is 
selected, it lists all the actions that can be performed on that contact. 

For information on the Invite to SoftPhone.com  menu item, see www,softphone.com.

Help

Provides access to various features. 
8
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Showing and Hiding Parts of the Softphone

You can still receive calls when X-Lite is hidden or minimized. If you exit when X-Lite is minimized, X-Lite 
will start next time as minimized.

Minimize to task bar

Show/hide dial pad

Close to system tray

Show/hide various tabs

Resize softphone

Open/close video window
9
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3.3 Placing a Call
You can place one more call when another call is already in progress.

You can specify the number to call by:

• Typing the number on the dialpad or computer keyboard, then clicking Call or Enter.
• Dragging and dropping an entry in the Contacts or History tab. You can control whether the phone call gets 

placed immediately or only after you click Call; choose Softphone > Preferences > Application.
• Right-clicking an entry in the Contacts or History tab.
• Redialing: click Call or click the down arrow and select a recent call and click Call.

The number can be in several formats:

• An extension such as 390 or 1300. X-Lite will place the call without going through your PBX.
• A phone number outside your PBX. See page 45 to set up correctly to place these calls.

Call entry field

Click to place the call

Auto complete suggestions

The first time you make a call, select Softphone > Preferences 
and set your dialing preferences. See page 45.

Place the call. See below 
for different ways to specify 
the number.

The outgoing call opens in its own call panel, below any other 
existing call panels. You will hear a ringing tone while X-Lite 
attempts to make a connection.
10
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• A phone number and extension with a separator in between. For example, 6045551222x1300. X-Lite will 
dial the phone number, wait for the call to get established, then dial the extension.
Valid separators are: x   extension   ext   ; (semi-colon) , (comma)

If X-Lite sees that the phone number is actually your own PBX, it drops the phone number and dials the 
extension directly.

• A SIP  address ((for example, kperera@yourNormalPBX.com)  Speak to your IT administrator or VoIP 
service provider about whether you can phone someone with a different domain from your own. 

Dealing with an Auto Attendant

If you know that your call will be answered by an auto attendant and you know what menu items you will 
choose, you can include those menu items (DTMF) in the phone number when you dial it:

• Before the first DTMF number, include at least one capital P.
• You can include other Ps. Each P causes X-Lite to wait one second before sending the next character. 
• At the end of the input, you must include a ; character.

Example: To dial a number, add a 3-second delay and then press 44, enter this in the call entry field:

604551212PPP44;

Example: To dial a number, add a 6-second delay, then press 1 then 3 then 2, each with a two second delay:

604551212PPPPPP1PP3PP2;

Placing another Call
To place a new call (without hanging up on the current call), simply place the call in the normal way. A second 
call panel opens below the current call. The first call is automatically put on hold.

Existing call is 
automatically put on hold

New outgoing call

Switch between the different calls by 
clicking Resume on the desired call 
panel. That call becomes the active 
call and all other calls are on hold. 
11
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3.4 Handling Incoming Calls
X-Lite must be running to answer incoming calls. (If X-Lite is not running, incoming calls may be directed to 
voicemail; check with your IT administrator or VoIP service provider.)

As soon as an incoming call is received, a call panel appears, showing information about the call.  

 

Action Description

Answer or Click Answer.
If you are on another call, that first call is automatically put on hold. You are 
now talking to the new caller.
Or press Enter (on the keyboard), if X-Lite is the active application.

Video The caller wants to include video.
Click to answer a video call and start sending your video immediately

Decline Click Decline. There will be a busy signal. The call may be directed to 
voicemail (if you have this service).
12
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3.5 Handling an Established Call

Volume control and

Speakerphone (this button is 
enabled if your computer has a 
speakerphone)

Mute

Place another call (current call is 
automatically put on hold). See page 11

Show/hide dialpad

Open or close the video window. If 
you close it, X-Lite stops sending 
your video to the other party.

Start your video. Even if you 
did not originally place a 
video call, you can add video 
at any time (if you have a 
camera).

Hold or resume the call

If a plus symbol appears here, 
you can add the current caller 
as a contact. 
13
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3.6 Handling Video Calls
Placing a Video Call

Specify the number by:

• Typing the number on the dialpad or computer keyboard, then clicking the arrow beside the Call button and 
choose Video call. 

• Right-clicking an entry in the Contacts or History tab and choosing Video Call
• Redialing: click the down arrow and select a recent call and choose Video call.

Adding Video
If you have a camera, you can click Start Video to add video to an established call. When you add video, the 
other party may (or may not) start sending their video to you.

Call entry field

Click the down arrow and 
choose Video call
14
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Other Party Adds Video
If the other party starts their video, your video window automatically opens and the video is played. You can 
start sending your own video, if desired (and assuming you have a camera) by clicking Start Video.

Pausing and Resuming Video
Click Stop Video or close the video window to pause sending your video.

Click Start Video to resume sending your video; the video window will open.

Status of your video

Control your video

Show/hide video window
15
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3.7 Three-way Calls (Conference Calls)

Starting a Conference Call

From the Dashboard

From an Existing Call 

• Enter the number or address by typing

• Or select from the redial list

Then choose Start Conference Call

• Or drag a contact or history item

From One Established Call

From Two Established Calls
16
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Managing the Conference
 

Removing a Participant
To remove one call from the conference, click the down arrow beside a participant name and choose Separate. 
The call becomes a separate call.

Ending the Conference
To hang up on everyone, choose End conference from the conference menu.

Suspending the Conference
To suspend the conference, choose Hold from the conference menu. All participants are put on hold. 

If you need to speak to one participant separately, put the conference on hold, separate the one participant from 
the conference, take that person off hold. When done, merge the participant back into the call.

Video Conference Calls
Calls made with X-Lite will work without a video camera, but a video camera is necessary to allow other parties 
to see your image. X-Lite will work with most USB video cameras.

Participant menu 

Mute. When you mute during a video call, 
you may also want to click Stop Video to 
stop the video feed.

This menu is disabled
17
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Including Video in a Conference
When you start a conference from established calls, video is automatically included if at least one of the calls 
already includes video and is sent to all the participants.

When you start a conference from scratch, video is not included. You can open your video window and choose 
to add video at any time. Video is sent to all the participants.

How Video Is Shared
The conference host (the person who starts the conference) serves as the host for other video. Whatever the 
conference host is receiving will automatically be sent to the other parties. 

If the conference host pauses or stops video, other participants will no longer receive video.

This person has video. 

This person does not have video. To remedy this 
situation, stop video and start it again. Video will be 
sent to all the current participants.

Closing the video window stops 
sending video.
18
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3.8 Voicemail
If your service includes voicemail and you have set up voicemail options (page 27), then when you have 
voicemail messages, a number appears beside the voicemail icon at the top of the phone. You can click the icon 
to automatically connect to voicemail and listen to your messages.

Voicemail icon is dark gray when 
you have a message waiting
19
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4 Using Resources

4.1 Contacts Tab
If the Contacts tab is not showing, go to the menu bar and choose View > Show Contacts.

The Contacts tab displays your contacts and lets you specify multiple contact methods for them.

Search field

Select display options

Add a Contact
21
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Managing Contacts

Adding a Contact

Click ,. The Contact Profile dialog appears. Complete the details and click OK.

Adding a Contact using an Existing Address
You can add a contact by capturing existing information. On the History tab, select an entry that is not a contact. 
Right-click and choose Add as Contact. 

Changing Contact Information
To change the information for a contact, right-click the contact and choose Edit Profile. 

Deleting a Contact
To delete one or more contacts, select them, right-click, and choose Delete. 

Exporting Contacts
You can export a contact list to a CSV, vCard or PST file. This is useful, for example, if you later upgrade to 
Bria 3 and want to move over your contacts.

1. From the main menu choose Contacts > Export Contacts. The Export Contacts wizard starts. 

2. When you click Next, the export starts. The result is:

• For a PST export, the existing .pst file is updated to include the entries from the X-Lite contact list. If 
Outlook is open, the entries immediately appear in the Outlook contacts. 
All information in the X-Lite contact list is exported to Microsoft Outlook. Only information that can 
be displayed in Outlook actually appears in the Outlook Contacts window. Typically this means that all 
softphone addresses are exported (and stored in custom fields) but not displayed in Outlook.

• For other formats, a new file of the specified type is created.
22
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Using Contacts

Contact Flyout
Single-click on a contact to show the Contact flyout. This flyout shows all the contact methods set up for the 
contact. You can click a contact method to perform its action.

Phone the person Drag the contact to the call entry field to start a phone call.

Phone the person Right-click and choose Call, then click the desired number.

Click a contact method
23



CounterPath Corporation
4.2 History Tab

Managing the Lists of Calls
You can right-click on an entry in a list to:

• Delete the call.
• Delete all entries in this list.
• Edit the profile if the entry is a contact.
• Add as contact. The Add a Contact dialog appears. 

Phoning from History
You can right-click on an entry to place a call to this person, using the contact method that was used for this 
call. You can also double-click to place an audio call.

Filter list

Incoming missed call

Incoming call that was 
answered

Outgoing call, either 
attempted or established
24



5 Configuring X-Lite

You can configure X-Lite in several ways:

• Configure global behavior. See “Configuring Preferences” on page 33.
• Configure the behavior on a per-account basis. See “Configuring your Account” on page 25.

5.1 Configuring your Account
Choose Softphone > Accounts. The Account Settings window appears. 

SIP Account Properties – Account
The red dot indicates that these 
fields are required
25



CounterPath Corporation
Field Description
Account name Always “My PBX”
Protocol Read-only. Always specifies SIP.

User Details
User ID Typically the account number for the account. For example, kperera. Provided by your IT 

administrator or VoIP service provider.
Domain For example, yourNormalPBX.com. Provided by your IT administrator or VoIP service 

provider.
Password Provided by your IT administrator or VoIP service provider.
Display name This name is displayed in the X-Lite title bar.

Other people will see you as this name.
Authorization name May not be required. If it is required, it will be provided by your IT administrator or VoIP 

service provider.

Domain Proxy
Register with domain and receive 
calls

Check this box if you want to receive incoming calls.
Typically, this field is checked. 

Send outbound via Choose the setting specified by your IT administrator or VoIP service provider: 
• Domain: If your VoIP service provider requires that traffic be directed to proxies that are 

discovered via the domain.
• Proxy Address: If your VoIP service provider has an outbound proxy address and requires 

that you provide the address to X-Lite. For the address enter a domain name (for example, 
domain.com) or an IP address (for example, 123.456.789.012). 
26
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SIP Account Properties – Voicemail

These settings let you set up to interact with your VoIP service provider’s or enterprise’s voicemail service. .
Your service provider may provide the ability to set up for voicemail outside of X-Lite, for example, by 
phoning a number and following the voice prompts, or by accessing a website. 
Check with your service provider or IT administrator to determine if another setup mechanism is available. If 
so, check what the settings are in that setup, and make sure you enter compatible information in X-Lite. 
 

Field Description
Check for voicemail Set the checkbox in one of these ways:

• Check the box if X-Lite must subscribe to be notified when there is a voicemail for 
you. In other words, to configure for “subcribe for message waiting”.

• Clear the checkbox if the service provider’s voicemail server sends notifications 
without X-Lite subscribing. In other words, to configure for “implicit subscription”.

• Clear the checkbox if the service provider does not support voicemail. 

Check with your IT administrator or VoIP service provider for the correct 
configuration.

Voicemail is offered by your enterprise or VoIP service provider; it is not part of X-
Lite. Contact your service provider for information on using voicemail.

Number to dial for checking voicemail Optional, but complete this field only if your VoIP service includes voicemail. 

• Completing this field activates the  icon on the softphone. When you click the 
icon,  X-Lite will dial this number. You will be connected to your service provider’s 
voicemail and can listen to your messages. 

• If you leave this field empty, then this icon will not work; you will have to manually 
dial this number in order to connect to voicemail.

Enter the number or SIP address provided by your IT administrator or VoIP service 
provider.

Number for sending calls to voicemail Complete only if your VoIP service includes voicemail. Optional, but you must 
complete it if you check “Send calls to voicemail if unanswered”.
This is the number that incoming calls will be forwarded to if they are unanswered after 
the specified interval (below).
If you leave this field empty, then X-Lite will never forward calls to your service 
providers’ voicemail. However, most enterprises or VoIP service providers have their 
own mechanism for sending unanswered phone calls to voicemail. So leaving this field 
blank does not mean that forward-to-voicemail does not work. 
Enter the number provided by your IT administrator or VoIP service provider.
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SIP Account Properties – Topology

Send calls to voicemail if unanswered Complete only if your VoIP service includes voicemail.
To send to voicemail after the specified number of seconds. 
Your service provider may also provide a similar feature that is set up outside of X-Lite. 
If so, make sure you do not enter competing information in X-Lite and in the service 
provider’s user interface. For example, if you turn off this field, make sure the same 
feature at your service provider is also turned off. Otherwise, all your calls will continue 
to be forwarded.

Field Description
Firewall traversal 
mode

Leave the default (Auto detect). Or if you have problems making phone calls, contact your IT administrator 
or VoIP service provider for information on the firewall traversal solution.
• Auto detect using ICE: Automatically determine the contact address for signaling traffic.

Advertise the local IP, public IP (discovered via STUN, if available), and media relay IP (discovered via 
TURN, if available), and use these to automatically determine the best route for media traffic during 
calls.

• Discover public IP address: Advertise the public IP address (discovered via STUN) for the contact 
address for signaling traffic, and for the connection address for media traffic.

• Use media relay (TURN): Advertise the public IP address (discovered via STUN) for the contact address 
for signaling traffic.

Advertise the address of a media relay server (discovered via TURN) for the connection address for 
media traffic.

• None: Advertise the local IP address only for both signaling and media traffic.
Server address • Empty: Discover the address of the firewall traversal server (the STUN or TURN server), if available, 

using DNS SRV. 
• Specified: Use the firewall traversal server specified as either an IP address or a fully qualified hostname.

Field Description
28
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Range of ports used 
on local computer

The appropriate setting depends on your computer setup:
• Checked: If your computer is behind a restrictive firewall that only allows specific port ranges to be 

used. Enter the range of ports to use for your SIP account. (You must also open those ports on your 
firewall; refer to applicable firewall documentation for information.)

• Unchecked: If your computer is not behind a restrictive firewall.   

Field Description
29
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SIP Account Properties – Transport

Field Description
Signaling Transport Contact your IT administrator or VoIP service provider to identify the types of transport that 

are supported. Then choose a supported transport:
• Automatic: X-Lite sets up the transport based on the capabilities of the network and the 

X-Lite computer. Choose this option if you do not care which transport is used.
• TCP: This transport provides no signaling security. 
• UDP: This transport provides no signaling security. 
• TLS: Choose this option to request signaling encryption or both signaling and media 

encryption.
Encryption Call encryption is supported only if you have a SoftPhone.com  account. See 

www.softphone.com.
30
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SIP Account Properties – Advanced

Field Description

Register Settings
Reregister every The time interval between X-Lite’s attempts to reregister in order to refresh the account 

registration for this account. A value of zero means not to reregister after the initial registration.
This value is placed in the “Expires” header field of the REGISTER message.

Minimum time If the reregistration fails, X-Lite will wait this amount of time, then attempt to reregister. If the 
second attempt fails, X-Lite will wait twice this time and try again, then four times this time, and 
so on, until reregistration succeeds.

Maximum time This is the maximum wait time between attempts to reregister. Once this maximum is reached, X-
Lite will wait this time for all subsequent attempts.
For example, the min. time is 20 secs, the maximum time is 120 secs. X-Lite will attempt to 
reregister as follows:Wait 20 secs; Attempt to connect; If fail, wait 40 secs; Attempt to connect; If 
fail, wait 80 secs; Attempt to connect; If fail, wait 120 secs (the maximum); Attempt to connect:If 
fail, wait 120 secs, and so on.

Timers
Enable session timers
Default session time

A session timer is a mechanism to detect whether a call session is still active from the signaling 
point of view. When the timer expires, a refresh is sent from one party to the other. The timer is 
then reset.
• Turn on to enable session timer. Enter a value in Default session time. 
• Turn off to disable session timer; refreshes will never be sent.
31
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Session timer preference This field specifies your preference for which party should send the refresh. The preference is not 
a guarantee that the refresh will be performed by the specified party. The choices are:
• None: No preference.
• Local refreshes: Your computer sends.
• Remote refreshes: The other party sends.
• UAC refreshes: The user agent client (the party that initiated establishment of the 

communications) sends.
• UAS refreshes: The user agent server (the other party) sends.

Hold Method Change this setting only if your IT administrator or VoIP service provider advises you to do so.
Send SIP keep-alives Typically on, to instruct X-Lite to send SIP keep-alive messages in order to maintain a “pinhole” 

through your firewall for SIP messaging.
Use rport Typically on.

Field Description
32
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5.2 Configuring Preferences
Choose Softphone > Preferences. The Preferences window appears. 

The Preferences panels let you control the way that you work with X-Lite. 

Preferences – Application

This panel lets you set your preferences for general GUI behavior. 
33
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Preferences – Sounds
 

 

 

 

 

 

 

 

 

 

 

 

You can assign specific sounds to a variety of actions or “events”.

1. Select the Enable sounds check box and select the check boxes for  each desired event, or clear the Enable 
sounds check box to disable all sounds.

2. If enabling sounds, you can change the sound for each event: select the individual event. The value in 
Sound preference will change. Select the desired sound.

You can import sounds; these will be added to the list of sounds you can choose from when assigning a sound to 
an event.
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Preferences – Devices

X-Lite automatically detects devices at each startup, and selects the most appropriate device for each purpose. If 
you do not like this selection, you can override it on this panel.

If you override a selection, it will apply the next time you start X-Lite, unless the device is no longer available, 
in which case X-Lite will again select the device to use.
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Field Description

Headset Mode

Speaker 
Microphone 

Change these fields only if you want to override the devices that X-Lite automatically selected.
In both these fields, select the headset you are using.
The headset is the device that is usually used for audio out (the sound you hear) and audio in 
(capturing your voice). The only situation in which the headset is not used is when the Speaker 
Phone button on the dialpad is pressed. 
Therefore, unless you will always be using X-Lite in speakerphone mode, you must make a 
selection here.
Select the headset in both the Speaker device field and Microphone device field.

HID Device If the selected headset device is a HID-compliant device, this field specifies that device. You can 
click Setup in order to assign functions to the device. For example, you can set the green button so 
that it answers an incoming call.

Speakerphone Mode

Speaker Change this field only if you want to override the devices that X-Lite automatically selected.
Make the appropriate choice:
• Select the device that you want to use for audio out (the sound you hear) when the Speaker 

Phone button is pressed. Make sure you select a speaker device (not the headset).
• Select None if you do not have a speaker phone. The Speaker Phone button on the dialpad is 

disabled.

Microphone Change this field only if you want to override the devices that X-Lite automatically selected.
Make the appropriate choice:
• Select the device that you want to use for audio in (capturing your voice) when the Speaker 

Phone button is pressed. 

It can be any microphone: it does not have to be the microphone on the device you specified as 
the speaker device. For example, it can be the microphone on your camera. 

• Select None if you do not have a speaker phone. The Speaker Phone button on the dialpad is 
disabled.

HID Device If the selected speakerphone device is a HID-compliant device, this field specifies that device. You 
can click Setup in order to assign functions to the device. For example, you can set the green button 
so that it answers an incoming call.
(If the speakerphone device is the same as the headset device and you have already configured the 
device, there is no need to click Setup again.)

Other Device

Ring On Change this field only if you want to override the devices that X-Lite automatically selected.
The device where you want to hear the phone ringing: the headset, the speakerphone, or none.

Camera Change this field only if you want to override the devices that X-Lite automatically selected.
Select the camera model.
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USB Device Button Setup
You can assign functions to a USB-compliant device. For example, you can set the green button so that it 
answers an incoming call.
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Preferences – Network

Field
Description

Select the type of network connection for your computer.

The sliders move to show the bitrate that will be used for sending and receiving. These rates are typical rates for 
the selected configuration.

If you know that your computer and network can handle a faster sending speed, click Custom and move the 
slider. It is recommended that you not change the receiving speed.

You will know that you have set the sending speed too high if:

• The remote video shows black areas or is slow or jerky.
• The remote audio is garbled.
• You will know that you have set the sending speed too low if the audio is good but the video is of poor 

quality (grainy).
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Preferences – Audio Codecs

This panel shows all the codecs that are included in X-Lite. You can enable or disable codecs as desired. 

With only one codec enabled, all calls made will use that codec. With more than one codec enabled, X-Lite 
automatically chooses the best codec based on the other party’s capability, the available bandwidth, and 
network conditions.

You cannot change the properties of any codecs.

About Codecs
Audio codecs describe the format by which audio streams are compressed for transmission over networks. 
Codecs can be categorized as either narrowband or wideband:

• Narrowband codecs work with low bandwidth such as a dialup internet connection. These codecs have a 
sampling rate of 8 kHz.

• Wideband codecs work with high bandwidths and result in better audio quality. However, they do not work 
with PSTN. These codecs have a sampling rate of 16 kHz.
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Supported Codecs
Codec Narrowband Wideband

Broadvoice-32

Broadvoice-32 FEC

DVI4

DVI4 Wideband

G.711aLaw *

G.711uLaw *

GSM

iLBC

L16 PCM Wideband

Speex

Speex FEC

Speex Wideband

Speex Wideband FEC

* Generally, at least one of these codecs must be enabled in order to 
place a PSTN (land line) call. 
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Preferences – Video Codecs

Video codecs describe the format by which video streams are compressed for transmission over networks. Some 
codecs require less bandwidth than others, but may result in lower video quality.

You can enable or disable codecs as desired. You may decide to disable a codec even though your enteprise or 
VoIP service provider supports it.

With only one codec enabled, all calls made will use that particular compression format. With more than one 
codec enabled, X-Lite automatically chooses the best codec based on the other party’s capability, the available 
bandwidth, and network conditions. 

You cannot change the properties of any codecs.
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Preferences – Media Quality

Audio Quality

Reduce echos Turning this feature on improves sound quality. This feature is typically on.

Reduce background noise Automatically attempts to remove background noise. Typically on for the speakerphone.

Automatic gain control This feature is typically on.

Preserve bandwidth When this feature is on, X-Lite stops sending audio when you are not talking.
When this feature is off, X-Lite always sends audio, which uses more bandwidth but may result 
in better call quality.
Typically off. However, if you are using a slow (dial-up or ISDN) connection, you may want to 
turn it on. 

Video Quality

Enable this option Check or uncheck to flip the video image.

Resolution – Limit available 
resolution

If you enable this field, X-Lite will determine the maximum quality that your computer can 
handle and will disable unapplicable options in the list of possible resolutions
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Resolution Leave at standard, or change the size as follows:
• Set it to high if you have a good camera and a computer with a fast CPU. You will know that 

you have set the size too large if:

Your computer slows down (the video is using too much CPU)
The video shows black areas or is slow or jerky.

• Typically set it to low only in special situations, for example, when using wi-fi in a hotel. You 
will know that you have set the size too small if the video is fuzzy.
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Preferences – Advanced

Field Description

DTMF You may need to change the DTMF configuration if you cannot interact with interactive 
voice response systems (auto attendants, voice-activated menus, and so on).

RTP This timer controls how calls are disconnected when X-Lite determines that there is a 
problem with the call and the other party has probably disappeared (assuming that you 
have not yourself detected the problem and hung up manually).
Typically, the timer is enabled. It is recommended that you not disable it.
You can change the length of the timer, but do not set it to less than 30 seconds.
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Preferences – Dialing Preferences

Field Description

Dial out prefix The number to dial out of your enterprise. For example, 9.

International prefix The prefix required on a phone number in order to handle this number as an international 
phone call. For example, +43. X-Lite handles international calling as follows:
• It looks at the phone number for this international prefix. 
• If it finds this prefix, the phone number is transformed so that the number can be 

successfully placed according to the phone rules for the country specified in the 
country code.

For example, if the phone number is +438901234 (meaning the number is a Swiss phone 
number) and the country code is Canada, then X-Lite replaces the + with 011 (the 
international dialing code for Canada), adds the dial out prefix (9) and places the call.

Default extension length The maximum length of extensions in your enterprise. This information must be correct 
to ensure that X-Lite can distinguish between a phone number that can be made without 
leaving your PBX and one that requires going through the PBX. 

Country code The country your phone system works in. Change this code if you go to another country, 
but only if your entrprise has an office in that country that has its own PBX. 
For example, if you go to your Geneva office and that office has its own PBX, change the 
country code to Switzerland. In this way, phone calls made to a Swiss phone number will 
be correctly placed (that is, as being placed from within Switzerland).
Do not change your country code if you go to another country but you are still connecting 
to the PBX in your home country. Speak to your IT administrator or VoIP service 
provider.
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Preferences – Privacy Options

This panel applies only if you have a SoftPhone.com  account. See www,softphone.com.
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A Troubleshooting
Choose Help > Troubleshooting to display the Troubleshooting window. 

Testing Audio and Video Devices
You can verify that your microphone, speakers and camera are working and can set the volume to a comfortable 
level without having to actually place a phone call.
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Testing Audio Quality
While you are on a phone call, you can test the quality of the audio. Note that to perform a valid test, you should 
be on an established call (not a call attempt). 
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Diagnostics

To start logging X-Lite activity and send a logging report to customer support:

1. Click Start Logging. The first Diagnostics Logging window appears.

2. Select the problem you are experiencing and click Start Logging. 

3. On the second Diagnostics Logging screen, click Finish. Logging will start.

4. Perform the actions you want to capture; for example, attempt to make a phone call.

5. When done, choose Help > Troubleshooting > Diagnostics again and click Send Report. Select the report 
and send it.

6. When the report has been sent, click Stop Logging. Click Done to close the Troubleshooting window.
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B Glossary
AEC Acoustic echo cancellation. Processing of the audio or video signal to reduce the echo 

effect that can arise with a speakerphone or that can arise if the sound from the 
speakerphone or headphone leaks into the microphone. 

AGC Automatic gain control. Processing of the audio or video signal to adjust the 
microphone volume level so that the other party does not hear the distortion that 
might be caused by too high a microphone input or too low volume (due to too low 
input level).

Broadband Broad or wide bandwidth. In data transmission, the wider the band, the more data it is 
possible to transmit in a given time span. A cable, DSL and ADSL connection to the 
network provide broadband for data transmission. A dialup or ISDN connection 
typically provide a narrow bandwidth for data transmission.

Codec The format by which audio or video streams are compressed for transmission over 
networks.

Dial plan The rules that X-Lite follows in order to interpret the phone number that the user has 
entered and to modify the number or address, as required, to ensure that the call will 
be placed successfully. 

DTMF Dual-tone multi frequency. DTMF is the system that is used in interactive voice-
response menu systems such as the menu system for accessing voicemail messages. 
The DTMF system allows the user to interact with the menu by pressing keys on a 
dialpad or keyboard.

HID Human interface device. In X-Lite, if the headset is HID-compliant, the user can 
configure the buttons on the device to invoke functions on X-Lite such as answering 
an incoming call.

IP Internet Protocol. A data-oriented protocol used for communicating data across a 
network. IP is the most common protocol used on the internet.

IP address A unique number that devices use in order to identify and communicate with each 
other on a computer network using the IP standard. 

Media In a VoIP phone call, the audio and video portion of the information in a call. 
Compare to “Signaling”.

MWI Message Waiting Indicator. An indicator that there is a voicemail message for the 
owner of an account.

Narrowband In data transmission, the wider the band, the more data it is possible to transmit in a 
given time span. A cable, DSL and ADSL connection to the network provide 
broadband for data transmission. A dialup or ISDN connection typically provide a 
narrow bandwidth for data transmission.

Proxy See SIP account.
PSTN Public Switch Telephone Network. The traditional land-line phone network.
RTP Real-time Transport Protocol. A protocol for delivering the media portion of a data 

transmission over an IP network. SRTP is another media protocol.
Signaling In a VoIP phone call, the information in a call that deals with establishing and 

controlling the connection, and managing the network. The non-signaling portion of 
the call is the Media.

SIP account An account that provides the user the ability to make VoIP phone calls. The account 
encapsulates the rules and functions the user can access.

SRTP Secure Real-time Transport Protocol. A protocol for delivering the media portion of a 
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data transmission over an IP network. SRTP is a secure protocol, which means that 
the media is encrypted. RTP is another media protocol.

TCP Transmission Control Protocol. A transport protocol for delivering data over an IP 
network. Other transport protocols are TLS and UDP.

UDP User Datagram Protocol. A transport protocol for delivering data over an IP network. 
Another transport protocol is TCP. 

VAD Voice Activity Detection. A technology that detects if audio is a human voice or 
background noise. X-Lite includes a feature (Preserve bandwidth on the Network 
panel of the Preferences window) that controls whether audio is transmitted when 
VAD determines that no one is actually speaking.

VoIP service provider A business that provides a VoIP service, allowing a user to connect to the internet in 
order to make VoIP phone calls using X-Lite. The VoIP service provider sets up a SIP 
account for the user. 
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